Is it supposed to look like this?

Post Reply
JeffStrom
Club Member
Club Member
Posts:856
Joined:Sat Oct 17, 2015 1:33 pm
Riding Style:Novice Track Rider
Achievement count:7
Is it supposed to look like this?

Post by JeffStrom » Wed Aug 18, 2021 9:28 am

20210810_080954.jpg
It is the connector between the stator and regulator. Looks like arcing inside the connector. It happened one day immediately on start (saw smoke) so I don't think it was just resistance in the connection. Static test on the stator and regulator looks fine. Will check voltage output of the generator next, but it may just need the connector replaced. Apparently this type of failure is common on that model and year. I'll probably do something different for the connector.
Jeff - Street Triple 675R / GSX-R600 / F850GSA

User avatar
fixxervi6
Ride Leader
Ride Leader
Posts:13800
Joined:Sat Oct 09, 2010 2:41 pm
Achievement count:36

Re: Is it supposed to look like this?

Post by fixxervi6 » Wed Aug 18, 2021 11:50 am

beamer?
K1600

User avatar
dufremle
Club Staff/Treasurer
Club Staff/Treasurer
Posts:12498
Joined:Fri Aug 25, 2006 7:57 am
Riding Style:Novice Track Rider
Achievement count:0
Location:NW Fort Worth
Contact:

Re: Is it supposed to look like this?

Post by dufremle » Wed Aug 18, 2021 11:51 am

Looks fine to me. :D

Wonder if some moisture got in there somehow.
Jim

2015 Yamaha YZF-R1
2015 RAM 1500 EcoDiesel

JeffStrom
Club Member
Club Member
Posts:856
Joined:Sat Oct 17, 2015 1:33 pm
Riding Style:Novice Track Rider
Achievement count:7

Re: Is it supposed to look like this?

Post by JeffStrom » Wed Aug 18, 2021 4:43 pm

fixxervi6 wrote:
Wed Aug 18, 2021 11:50 am
beamer?
GSX-R. Looking at the Gixxer forums, this is a common issue for the bikes from the early to mid 2000's. Should be an easy fix as long as it didn't fry something down the line.
Jeff - Street Triple 675R / GSX-R600 / F850GSA

JeffStrom
Club Member
Club Member
Posts:856
Joined:Sat Oct 17, 2015 1:33 pm
Riding Style:Novice Track Rider
Achievement count:7

Re: Is it supposed to look like this?

Post by JeffStrom » Wed Aug 18, 2021 4:50 pm

dufremle wrote:
Wed Aug 18, 2021 11:51 am
Looks fine to me. :D

Wonder if some moisture got in there somehow.
I suppose it is possible. But then I don't ride it in the rain and I had dielectric grease in it. I'm considering putting each of the three wires in individual insulated connectors to improve the isolation.
Jeff - Street Triple 675R / GSX-R600 / F850GSA